
Rice Lake Tools
Quick Setup Guide
Rice Lake Tools enables the user to configure compatible indicators through a PC interface. The purpose of this quick setup 
guide is to walk a user through the basic steps to: 

• Ensure that the compatible Rice Lake indicator is configured correctly to communicate with the Rice Lake Tools 
application 

• Establish communication between RLTools and a compatible indicator 
• Create a scale profile within RLTools
• Configure scale settings in RLTools
• Perform calibration through the RLTools calibration wizard
• Export and import settings as an .xml file

To learn about additional specifications and capabilities of the software, see the Rice Lake Tools technical manual (PN191448).
Manuals are available from Rice Lake Weighing Systems at www.ricelake.com/manuals
Warranty information is available at www.ricelake.com/warranties

Preparing Hardware and Software
Before the indicator and the PC can communicate, all hardware and software must be properly configured. This includes the 
indicator, the hard-wired connection and the PC.

Configuring the Indicator
RS-232 Connection
The indicator’s serial settings must be set to communicate through the RS-232 port and the communication mode must be set 
as onde in order for the indicator to communicate directly to a PC. For more information, refer to the indicator’s technical 
manual.

1. Navigate to Setup>Serial>PC Sel>232 Press to confirm. Com.prn displays.
2. Navigate to Com.pC>PCmode>onde.
3. Press Enter.
4. Press and hold the C key. SAVE displays.
5. Press Enter.

Configuring the Connection
Connect the PC directly to indicator. Most indicators use an RS-232 cable to connect to a serial com port on the PC (PN22436). 
See Figure 1 for wiring pinout chart. See indicator’s technical manual for indicator wiring. 

   
Figure 1. RS-232 Pinout chart

NOTE: Troubleshooting tip: If indicator is having trouble connecting to the PC, flip the wiring of pin 2 and 3 at the indicator 
and try again. If needed, perform a loopback test to verify the port is good.

i

1 2 3 4 5

6 7 8 9

Pin No. Symbol Description
1 -- Not Used
2 Rx Received Data 
3 Tx Transmitted Data
4 -- Not Used
5 GND Ground
6 -- Not Used
7 -- Not Used
8 -- Not Used
9 -- Not Used
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Configuring the PC
Search www.ricelake.com for the latest version of RLTools. To install RLTools in the PC, download and launch the installation 
executable file and follow the suggested steps. Install all suggested driver updates.
To launch the program:

• Click on the connection automatically created on the desktop
– OR –

• Select in the Windows® START menu, Rice Lake Tools>Rice Lake Tools
If the PC is connected to the internet, RLTools will automatically search for driver updates.

NOTE: Troubleshooting tip: If the installation wizard does not prompt driver updates and the package of files from Rice 
Lake Weighing included .xml driver files, copy the included .xml files to the Rice Lake Tools Setup folder in the PC 
(C:\Program Files (x86)\RiceLakeTools\Setups <or similar>). This prompts driver installation upon startup.

Initializing Communication between PC and Indicator
Follow the steps below to initialize communication between PC and indicator:

1. Click on the  icon in the lower right corner of the RLTools application status bar. Or from the main menu, select 
Tools>Communication and the following window displays:

 
Figure 2. Indicator Communication Dialog Box

• Port specifies which port is connected to the weight indicator; Select the number of the connected communication port. 
If using a USB adapter, insert USB cable and press Reload ports to discover USB port.

• When using an RS-232 connection, 485 address, IP Address, and TCP/UDP Port should all be left blank
• Default PC communication settings such a bits per second () and data bits, parity and stop bits () match 

default indicator communication settings. For more information on each of the fields, see the Rice Lake Tools 
technical manual (PN191448) and the technical manual of the connected indicator.

2. Press Test to initialize test program once applicable fields are set; this verifies the correct setting of the configuration 
parameters. Either the Test successful or No scale found message displays.

NOTE: Troubleshooting tip: If No Scale found message displays, confirm indicator settings and port number. It may also be 
necessary to flip the wiring of the Rx and Tx at the indicator.

3. If test is successful, press OK to confirm connection or press Cancel to exit without saving. If scale is connected, the 
square in the bottom right corner of the RLTools application status bar turns green. 

NOTE: Alternatively, use a micro USB adapter to establish communication between the indicator and the PC. 

https://www.ricelake.com
http//www.ricelake.com
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Creating A New Scale Profile
Once communication has been established between the scale and the indicator, a scale profile must be created. A scale profile 
is linked to a customer profile. This guide uses the default customer profile (DEMOKIT) that is included in the software. See the 
Technical manual for creating a unique customer profile. Follow these steps to create a new scale profile:

1. Ensure indicator is in Setup mode.
2. Click to highlight a customer in the menu tree located on the left side of the window.

Figure 3. Customer Menu Tree

3. To open the Scale’s Management dialog box proceed in one of the following ways:
• Select File>New from the main menu
• Use CTRL+N fast keys
• Click New in the tool ribbon
• Right click on the highlighted customer and select the New Scale item.

The following dialog box displays:

Figure 4. Scale’s Management Dialog Box

4. Enter a name for the scale in the description box. This is viewable in the menu tree in the left window.
5. Enter annotations in the notes box if desired.
6. Click Create Scale - the following dialog box displays the firmware version of the scale.

NOTE: The serial number and version automatically populate the scale management dialog box when the scale is created. 
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Figure 5. Scale Created Successfully

7. Click OK to confirm. The scale description displays in the tree menu on the left of the home screen.

Scale Setup
Within each scale, the user can set up multiple scale setups. These setups can be saved, imported from and exported to the 
indicator. Follow this procedure to create a new setup profile.

1. Ensure that the indicator is in setup mode.
2. Click to highlight SETUPS in the menu tree located on the left side of the window.

 
Figure 6. Menu Tree

3. Open the scale’s setup dialog box in one of the following ways:
• Select File>New from the main menu
• Use CTRL+N fast keys
• Click New in the tool ribbon
• Right-click on SETUPS and select New Setup

The following window displays containing the default parameters of the setup, subdivided into folders.

Figure 7. Setup Management Window

https://www.ricelake.com


Rice Lake Tools Quick Setup Guide

© Rice Lake Weighing Systems ● All Rights Reserved 5

4. Enter a name for the setup in the name field and, if desired, a description of the setup in the notes field.
5. Click Get to acquire current settings from indicator.
6. Adjust parameters as needed. 

NOTE: Click the question mark next to each parameter to display an info window explaining that parameter.
This dialog box mirrors all of the settings available in the indicator’s setup menu. For detailed information on scale setup, 
see the technical manual of the indicator that is being set up.

7. Click Save to save parameters as a scale setup.
8. Click Send if parameters were adjusted to transmit the updated setup to the indicator.
9. Click Save and Exit to save the setup to the scale profile on the PC and store setup configuration on the indicator. The 

indicator will reboot.
NOTE: If PCmode parameter is changed or the serial parameters are changed in the configuration and sent to the indicator, 
the indicator will lose communication with RLTools.
Configuration files can be exported and imported to scale setup. 

Calibration Tool 
To initialize the calibration tool from the main menu:

1. Ensure that connected indicator is in setup mode.
2. Click to highlight the scale profile in the menu tree located on the left side of the window.
3. To open the calibration tool, select Tools>Calibration Tool from the main menu. The following displays:

Figure 8. Calibration Tool Selection Menu

NOTE: Calibration Tool 2 is also used for SCT-4X and SCT-1SX instruments. 

4. Select the appropriate tool option for the scale type. 
5. Click OK. 
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Calibration Tool Option 1
The following dialog box displays:

Figure 9. Calibration Tool Option 1 Dialog Box

IMPORTANT: See Initializing Communication between PC and Indicator on page 2 if a Connected message doesn’t appear 
at the bottom-left of the box. 

1. Click on the Wizard Icon in the tool ribbon. The following dialog box displays:

Figure 10. Calibration Wizard

NOTE: The calibration wizard has the capability of Real Calibration with sample weights, Zero Calibration, Theoretical 
Calibration and Equalization (A Pre-Calibration of the indicator). This quick start guide addresses Real Calibration. 
Reference the Rice Lake Tools Technical Manual for information on all other calibration procedures.

https://www.ricelake.com
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2. Select Real Calibration and click Next; the following displays:

Figure 11. Chanel Selection Dialog Box

3. Select the first channel to be calibrated. 
NOTE: Always select Channel 1 if the scale mode is set to dependent channels. The SCT-2200 does not have multiple 
channels. If configuring an SCT-2200 always select Channel 1.

4. Click Next to confirm, after which the following displays:

Figure 12. Setup Parameters Dialog Box

5. Select the operation to perform. Selection will define starting point of calibration. 
• Receive setup from scale - Downloads metrologic data from scale as a starting point for calibration
• Load setup from file - Prompts user to select a new calibration setup from file
• Check the parameters of the present setup - Uses calibration stored in current scale profile of RLTools
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6. Click Next to confirm. The following displays:

Figure 13. Setup Parameters

7. Click on any Change key to modify the relative parameter:
• Decimal point
• Unit of measure
• Division
• Capacity
• Single range
• Multi range
• Multi division

8. Click Next to continue. The following displays:

Figure 14. Select Number of Calibration Points

https://www.ricelake.com
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9. Set the number of calibration points (other than the scale zero) and press on Next to continue:

Figure 15. Zero Acquisition Dialog Box

10. The program is ready to acquire the scale zero; unload the scale and press on Next. The following displays:

Figure 16. Acquisition of Point 1

11. Enter the calibration weight value (500 lb for example) and press on Next. The following displays: 

Figure 17. Acquisition of point 1
12. Load scale with previously defined calibration weight value and press on Next.
13. Repeat step 11 for the remaining calibration points. 
14. For all desired channels, select Restart Wizard and repeat steps 1-13. 
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15. Select Terminate calibration when all configured channels are calibrated. Press Next. The following displays:

Figure 18. Calibration Terminated Successfully
16. Select Transmit setup to the scale. Press Next to transmit the calibration data to the indicator. The following displays:

Figure 19. Close or Restart Wizard

17. Select Close Wizard and press End. The calibration tool dialog box displays.
18. Press Exit in the upper right to close the program. The main menu of RLTools displays.

https://www.ricelake.com
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Calibration Tool Option 2
1. The following dialog box displays. 
2. Select Connect. 

Figure 20. Calibration Tool Option 2 Dialog Box

3. The following message displays. 
4. Select the Calibration tab.

Figure 21. Successful Connection Message
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5. The following parameters display. 
6. Select Start Calibration.

Figure 22. Calibration Tab Parameters

7. The following displays. 
8. Select any field to modify the parameter.
9. Unload the scale and select Capture Zero. 

Figure 23. Capture Zero Dialog Box

https://www.ricelake.com
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10. Enter the calibration weight value (in the example, 500 lbs).
11. Load scale with previously defined calibration weight value. Select Capture Point.

Figure 24. Calibration Weight Value

12. Repeat steps 5 and 6 for the remaining calibration points. 
13. Select Disconnect and press Exit. The RLTools main menu displays.

Figure 25. Calibration Complete
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Exporting/Importing a Setup Configuration from File
Scale setup configuration can be exported to an *.xml file and saved to the PC. The file can be imported into another scale or 
used as a backup to restore scale configuration. 

Exporting to *.xml
1. Ensure that connected indicator is in setup mode.
2. To open the setup management dialog box, right click on the scale setup on the left side of the main menu.

Figure 26. Edit Selected Setup

3. Select Edit selected setup from the menu. The following dialog box displays:

Figure 27. Setup Managment

4. Click Export at the bottom of the dialog box.
5. Navigate to desired location. Click Save to export .xml file.

Importing from *.xml
1. Ensure that connected indicator is in setup mode.
2. To open the setup management dialog box, right click on the scale setup on the left side of the main menun
3. Click Import at the bottom of the dialog box.

https://www.ricelake.com
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4. Navigate to location of *.xml file. Click Open to import .xml file.

Figure 28. Import file

5. Imported settings populate the setup management dialog box.
6. Click Send to transmit the setup to the indicator.
7. Click Save and Exit to save the setup to the scale profile on the PC and store setup configuration on the indicator. The 

indicator will reboot.
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